Como especialistas en marketing, nos encantan los números grandes. 500 publicaciones vistas? 500 nuevos prospectos hoy? ¡Fantástico!
Pero a veces los números altos no son tan buenos. Lo último que cualquier propietario de un sitio web querría ver al abrir su página de inicio es esto:

¿Cuándo obtendrás Error interno de servidor 500 en su sitio de WordPress, detiene toda su operación y lo pone apurado para encontrar una solución.
La buena noticia es que este es un problema común en WordPress. Y con un poco de investigación, generalmente hay una solución simple. En este artículo, le mostraré por qué su sitio «actualmente no puede manejar esta solicitud» y cómo deshacerse de este mensaje.
Error HTTP 500 en WordPress: ¿qué significa «actualmente no se puede manejar esta solicitud»?
Cuando visita un sitio web, el navegador envía una solicitud al proveedor de alojamiento web solicitando que se cargue el sitio web. Si hay algún problema con su sitio web que impide que el servidor de alojamiento entregue esta página a su navegador (es decir, no puede manejar la solicitud), le enviará un mensaje de error. Este es un error interno del servidor 500.
El error HTTP 500 puede deberse a varias causas diferentes, pero probablemente no sea un problema con el servidor host en sí. Lo más probable es que el host no pueda descargar el contenido de su sitio de WordPress por algún motivo.
Gracias a CMS WordPress Las causas más comunes de un error interno del servidor 500 son:
- complementos o temas defectuosos
- archivo .htaccess corrupto y/o
- Límite de memoria PHP excedido.
A veces, el problema también puede provenir del servidor de alojamiento.
La vaguedad del 500 hace que sea difícil de manejar; la buena noticia es que probar algunas reparaciones casi seguramente resolverá su problema. Esto es lo que debe hacer:
Cómo reparar el error interno del servidor 500 en WordPress
- Haz una copia de seguridad de tu sitio.
- Habilite la función de depuración de WordPress.
- Desactiva tus complementos.
- Deshabilitar el tema actualmente activo.
- Verifique su archivo .htaccess.
- Verifique su límite de memoria PHP.
- Reemplace sus archivos principales de WordPress.
1. Haz una copia de seguridad de tu sitio.
Resolver el problema requerirá cambiar algunos elementos en el sitio, incluidos algunos cambios en complementos, temas y posiblemente archivos centrales de WordPress. Incluso si su sitio está inactivo, haga una copia de seguridad de sus archivos en caso de que pierda sus datos y necesite revertirlos.
Guarde la copia de seguridad en un lugar seguro. Espero que no lo necesites, pero es bueno tenerlo por si acaso.
2. Habilite la función de depuración de WordPress.
WordPress incluye un práctico depurador para ayudarlo a solucionar tales problemas. Cuando algo sale mal, el registro de errores informará los detalles del problema.
El depurador está deshabilitado de manera predeterminada; habilítelo primero siguiendo los pasos a continuación:
1. Acceda a su sitio web a través de FTP.
2. Abre los tuyos public_html carpeta o cualquier directorio que contenga archivos de WordPress.
3. Buscar y hacer clic derecho wp-config.php archivo, luego seleccione Mostrar cambios.
4. Una vez que el archivo esté abierto, desplácese hasta la parte inferior del archivo y pegue la siguiente línea de código:
define( 'WP_DEBUG', true );
Este código le dice a WordPress que registre errores en su sitio.
5. Guarde sus cambios y vuelva a cargar su sitio. En la pantalla de error, puede ver un informe más detallado que identifica el origen del problema; esto podría apuntar a un complemento o archivo específico. Si la fuente del problema aún no está clara, sigue leyendo.
Cuando haya terminado de usar el depurador, asegúrese de apagarlo eliminando el código agregado anteriormente y guardando el archivo, ¡tenga cuidado de no cambiar nada más!
3. Desactive sus complementos.
La causa probable de este error es que uno de sus complementos (o una combinación de ellos) está causando un mal funcionamiento de su backend. La mejor manera de probar esto es desactivar todos los complementos y luego reducirlo al culpable.
Si puede acceder a la cuenta de administrador, pruebe las siguientes soluciones:
1. Seleccionar desde el escritorio Complementos> Complementos instalados.
2. Marque la casilla junto a él Enchufar para seleccionar todos los complementos.
3. Elegir Desactivar de Acciones masivas menú desplegable, luego haga clic en Usar.
4. Actualice su sitio. Si ya no ve el error, comience a activar cada complemento de uno en uno y vuelva a cargar su sitio web después de cada activación para identificar el complemento defectuoso.
Si no puede acceder a las opciones de administrador, debe conectarse a su servidor con protocolo de transferencia de archivos (FTP). Una vez conectado, verá todos sus archivos para su sitio de WordPress. Siga los pasos a continuación:
1. Para abrirlo public_html carpeta (o dondequiera que sus archivos de WordPress estén almacenados en su servidor) y luego abra wp-content carpeta.
2. Renombra el tuyo enchufes carpeta «plugins_old».
3. Actualice su sitio web. Si tu sitio funciona, cámbiale el nombre plugins_stare carpeta de nuevo a «complementos».
4. Dentro de enchufes carpeta, cambie el nombre de cada carpeta de complementos una por una hasta que encuentre el complemento que causa el error.
Si encuentra un complemento específico que causa el error, reemplace el complemento o notifique a su desarrollador.
4. Deshabilite el tema actualmente activo.
Si los complementos no son el problema, podría ser su tema de WordPress, especialmente si es de un desarrollador externo. Para verificar esto, comience reemplazando temporalmente el tema actual con su tema predeterminado de WordPress. Si tiene acceso al Control del administrador, siga estos pasos:
1. Elegir Apariencia> Temas desde el tablero de WordPress.
2. Active cualquier tema predeterminado de WordPress, como veinte diecinueve.

3. Verifique su sitio web para ver si hay un mensaje de error HTTP 500.
Si no puede acceder a la cuenta de administrador, debe utilizar un cliente FTP para acceder al sitio. Luego haz lo siguiente:
1. Para abrirlo public_html carpeta (o donde estén almacenados sus archivos de WordPress) y luego abra wp-content carpeta.
2. Para abrirlo temas carpeta y busque la carpeta activa del tema.
3. Agregue «_old» al final del nombre de la carpeta activa del tema. Esto deshabilita el tema.
4. Actualice su sitio web. Si funciona, has encontrado el problema. Póngase en contacto con el creador del tema sobre el error y solicite la última versión del tema.
5. Verifique el archivo .htaccess.
La siguiente causa probable del error interno del servidor 500 en WordPress está dañada .htaccess un archivo ubicado en la raíz de los archivos de su sitio web (generalmente public_html). Este archivo contiene varios consejos para el servidor host, como permitir la protección con contraseña para sitios web y redireccionar URL.
Al igual que cualquier otro archivo fuente, cualquier error tipográfico o modificación no válida en el .htaccess descifrará el código y potencialmente su sitio web. Siga los pasos a continuación para asegurarse de que funcione:
1. Conéctese al servidor a través de FTP o el escritorio de cPanel.
2. Abre los tuyos public_html carpeta (o la carpeta que sea la raíz del sitio).
3. Fundar .htaccess expediente. Su servidor puede ocultar este archivo de forma predeterminada, en cuyo caso cambie la configuración de su vista para mostrarlo. Rebautizar .htaccess archivo para algo como esto .htaccess_test.
4. Actualice su sitio web. Si ya no ve el error HTTP 500, significa .htaccess es la fuente del error. Si todavía ves 500 .htaccess esto no es un problema y puede continuar con el siguiente paso verificando su límite de memoria PHP.
5. Arreglar .htaccess, simplemente reemplácelo por uno nuevo. Desde el tablero de WordPress, seleccione Ajustes > Enlaces permanentes.
6. haga clic aquí guardar cambios al final de la página. Esto reemplaza al antiguo .htaccess expediente.
6. Verifique el límite de memoria de PHP.
El límite de memoria PHP de su sitio lo asigna su instalación y host de WordPress. Si su sitio excede la capacidad de la memoria, informará un error de servidor interno 500. Para aumentar su límite de memoria, intente estos pasos:
1. Acceda a los archivos de su servidor a través de FTP o cPanel.
2. Vaya a la raíz del sitio y busque el archivo. wp-config.php. Este archivo contiene una regla que especifica el límite de memoria. Haga una copia de este archivo como respaldo.
3. abierto wp-config.php y busca el código «WP_MEMORY_LIMIT«. Si lo encuentra en el archivo, reemplace el valor en esta regla con «64M». De lo contrario, pegue esta línea de código en la parte inferior del archivo:
define('WP_MEMORY_LIMIT', '64M')
4. Actualice su sitio web. Si el error desaparece, se ha encontrado el problema.
Esta es solo una solución temporal: si excedió el límite de memoria, deberá averiguar por qué. Es posible que su sitio web haya crecido demasiado, en cuyo caso debe actualizar su plan de alojamiento para satisfacer sus necesidades de almacenamiento.
Sin embargo, otra causa potencial es un complemento o tema que está agotando su memoria. Para verificar esto, comuníquese con su proveedor de alojamiento y solicite un informe de uso de recursos, o encuentre esta información usted mismo si su host tiene acceso a ella.
7. Reemplace sus archivos principales de WordPress.
En algunos casos, sus archivos principales de WordPress pueden haber sido modificados incorrectamente por un complemento o tema. Si ha llegado hasta aquí sin ninguna solución, puede valer la pena reemplazar sus archivos principales actuales con archivos limpios y sin modificar. Si bien aún tendrá datos del sitio después de este cambio, es posible que deba volver a cambiar algunas de sus configuraciones originales.
Para reemplazar el núcleo de WordPress:
1. Descargar WordPress y descomprímalo en tu dispositivo.
2. Principalmente wordpress carpeta, eliminar wp-config-muestra.php y wp-content carpeta. Si no elimina estas cookies, sobrescribirán los datos de su sitio actual.
3. Use su cliente FTP para colocar nuevos archivos principales de WordPress en el servidor de alojamiento y reemplace los archivos actuales.
Si eres un aprendiz más visual, aquí hay un video que cubre todos estos pasos.
Si todo lo demás falla …
Como último recurso, comuníquese con el soporte de su proveedor de alojamiento; en este caso, el problema puede estar en su servidor. Explique su solución de problemas y ellos revisarán la configuración y los registros de su servidor para encontrar la causa. Aquí es donde la calidad del servicio al cliente realmente se destaca del proveedor de alojamiento.
Los errores internos del servidor son tan frustrantes porque son ambiguos y, a veces, incluso engañosos. Aun así, siguiendo los pasos anteriores, es de esperar que salga con un impacto mínimo en su sitio de WordPress y su reputación.
Una nota más: tenga cuidado con este tipo de errores al cambiar su sitio. Le recomendamos encarecidamente que pruebe nuevos temas, complementos y actualizaciones en un sitio de prueba. De esa manera, si obtiene 500, sus visitantes no lo verán en su sitio en vivo y no intentará obtener una solución.








